Mercurial ssl wrong version (_ssl.c:581)

41 0

При обновлении сайтов на Debian jessie, точнее при hg pull или hg push начал получать ошибку вида:

abort: error: [SSL: WRONG_VERSION_NUMBER] wrong version number (_ssl.c:581)

Проблема оказалась в том что bitbucket перестал поддерживать старые версии mercurial.

Поэтому для старых версий ОС решение простое и незамысловатое:

root$ pip install mercurial

Только не забудьте предварительно удалить старую версию.

Комментарии

Контактные данные

 Россия, г. Москва